WordPress[Revive Old Post] アップデート後に過去記事自動ツイートが停止

WordPress[Revive Old Post] アップデート後に過去記事自動ツイートが停止

WordPress[Revive Old Post] アップデート後に過去記事自動ツイートが停止

こんにちは。@dmgadget_ディーエムガジェットです。ちょっと前までブログの過去記事の自動ツイートは「Tweetiy」を使っていましたが去年の12月から使えなくなってしまい、かわりに「Revive Old Post」を使うようになりました。

WordPress[Revive Old Post] アップデート後に過去記事自動ツイートが停止

「Revive Old Post」の導入に関してここではまだ何も書いていなかったと思いますが、先日プラグインを最新版にアップデータした後から過去記事が自動ツイートされていないことを知って解決策を探していました。同じ問題を抱えている人もいらっしゃるかと思いますので備忘録としてここに残したいと思います。

Advertisement

プラグインディレクトリのFAQページに解決策が記載されていました

Before asking any question you need to check if you have the latest version, either PRO or FREE.

Plugin doesn’t post at the regular interval or sends more posts than it should send to social networks.

Unfortunately wp_cron function isn’t perfect, it trigger just when somebody visit your site, so you nobody visit your site in 3 hours, ROP won’t trigger. In order to achieve this you need to enable Remote Check and add this line to your wp-config.php right after the lines with database

credentials:
define(‘DISABLE_WP_CRON’, true);

なんとなく翻訳するとWordPressの「wp_cron機能」が完璧ではないため、修正には「wp-config.php」に以下の記述をしてください。とのこと他にも

You need to add this line to your wp-config.php right after the lines with database credentials:

define(‘ALTERNATE_WP_CRON’, true);

If new version doesn’t works

Try other versions from //wordpress.org/extend/plugins/tweet-old-post/download/
Manually upload it in your plugins folder, activate and use.
Note: Do not upgrade your plugin if you want to use the older version.

以下のコードを同じく「wp-config.php」に記述してください。又、それでも正常に動かない場合は新しいバージョンのプラグインではなくて前のバージョンをお使いください。みたいな事が記載してありました。

と云う事で上記の2文をWordPressの「wp-config.php」に記載します。

Advertisement

FTPアプリでルートディレクトリ(フォルダ)にアクセス

お使いのFTPアプリでWordPressがインストールしてあるサーバーのルートディレクトリ(フォルダ)にアクセスして「wp-config.php」を開きます。自分は「Transmit」を使っています。


Transmit
カテゴリ: ユーティリティ, 仕事効率化

「wp-config.php」を開いたら、先程「Revive Old Post」のFAQに記してあった動作を改善する為の下記の記述をコピペします。

define(‘DISABLE_WP_CRON’, true);
define(‘ALTERNATE_WP_CRON’, true);

「wp-config.php」の一番下にペースとすれば問題ないと思います。ペースト後ファイルを保存して、「Revive Old Post」のプラグイン設定ページをもう一度開いてみてください。New Versionでも問題なければ動作すると思われますが、それでも自動ツイートされない方は、下記から過去のプラグインバージョンをインストールしてお使いください。ダウンロードページは以下となります。

読んで頂いてありがとうございました。

Advertisement

WORDPRESSカテゴリの最新記事